[SFML] cannot open file 'sfml-network-d.lib'
Panel użytkownika
Nazwa użytkownika:
Hasło:
Nie masz jeszcze konta?
Zarejestruj się!

[SFML] cannot open file 'sfml-network-d.lib'

AutorWiadomość
Temat założony przez niniejszego użytkownika
[SFML] cannot open file 'sfml-network-d.lib'
» 2018-05-11 15:05:53
Witam, zaczynam przygodę z SFML. Nie udało mi się z Code::Blocks więc próbuję z Microsoft Visual studio bo z tego co widzę większość z tego korzysta. Dołączyłem w Properties>C/C++>General>Additional Include Directories ścieżkę do folderu include w folderze SFML oraz w Linkerze ścieżkę do folderu lib, następnie w Input dodałem Additional Dependencies wszystkie pliki .lib (od main do network). Wydaje się że wszystko jest połączone a jednak nie działa.
Jeżeli ktoś byłby w stanie pomóc byłbym ogromnie wdzięczny.
P-171001
» 2018-05-11 15:26:24
Masz napisane w błędzie, że nie można otworzyć pliku, więc ścieżki nie są poprawne.
P-171002
Temat założony przez niniejszego użytkownika
» 2018-05-11 15:31:50
pekfos, są poprawne na 100%, skopiowałem ścieżki do tych folderów i wkleiłem.
P-171003
» 2018-05-11 15:41:04
Co masz w Linker/Command Line?
P-171004
Temat założony przez niniejszego użytkownika
» 2018-05-11 15:43:46
/OUT:"C:\Users\wojtek\source\repos\SFML-temp\SFML-template\Release\SFML-template.exe" /MANIFEST /LTCG:incremental /NXCOMPAT /PDB:"C:\Users\wojtek\source\repos\SFML-temp\SFML-template\Release\SFML-template.pdb" /DYNAMICBASE "sfml-main.lib" "sfml-graphics.lib" "sfml-window.lib" "sfml-system.lib" "sfml-audio.lib" "sfml-network.lib" "kernel32.lib" "user32.lib" "gdi32.lib" "winspool.lib" "comdlg32.lib" "advapi32.lib" "shell32.lib" "ole32.lib" "oleaut32.lib" "uuid.lib" "odbc32.lib" "odbccp32.lib" /DEBUG:FULL /MACHINE:X86 /OPT:REF /SAFESEH /PGD:"C:\Users\wojtek\source\repos\SFML-temp\SFML-template\Release\SFML-template.pgd" /MANIFESTUAC:"level='asInvoker' uiAccess='false'" /ManifestFile:"Release\SFML-template.exe.intermediate.manifest" /OPT:ICF /ERRORREPORT:PROMPT /NOLOGO /LIBPATH:"C:\Users\wojtek\source\repos\SFML-temp\ExtLibraries\SFML\lib" /TLBID:1
P-171005
» 2018-05-11 16:02:43
Spróbuj dopisać \ na koniec ścieżki do katalogu bibliotek.
P-171006
Temat założony przez niniejszego użytkownika
» 2018-05-11 16:17:17
Niestety nic to nie zmieniło.
P-171007
» 2018-05-11 16:32:04
Na pewno ustawiłeś wszystko dla właściwej konfiguracji? Błąd z tytułu mówi o bibliotece z "-d", w tym poleceniu nie masz takiej.
P-171008
« 1 » 2
 Strona 1 z 2Następna strona