C++ + SFML jak zrobić?
Panel użytkownika
Nazwa użytkownika:
Hasło:
Nie masz jeszcze konta?
Zarejestruj się!

C++ + SFML jak zrobić?

AutorWiadomość
Temat założony przez niniejszego użytkownika
C++ + SFML jak zrobić?
» 2018-09-09 18:01:45
Witajcie kochani.
To mój pierwszy post na forum. Otóż mam problem.
Tak wiem, że na stronie są kursy, konfiguracje itp. dotyczące bibliotek SFML, ale one dotyczą starych wersji.
Posiadam Dev C++ 5.11 i próbowałem go łączyć na wszelakie sposoby z różnymi wersjami SFML i za cholere nie idzie nic skompilować. Nie mam pojęcia jaką wersje SFML powinnem mieć.
Jaką dokładnie biblioteke SFML powinnem pobrać dla kompilatora Dev C++ 5.11 tak aby była w 100% kompatybilna?
P-172282
» 2018-09-10 00:12:22
Ściągnij sobie Visual Studio dla C++, masz tam pakiety nuget i samo sciaga, musisz tylko biblioteki dolinkowac
P-172283
» 2018-09-12 20:00:33
Jaką dokładnie biblioteke SFML powinnem pobrać dla kompilatora Dev C++ 5.11 tak aby była w 100% kompatybilna?
Chciałeś powiedzieć: dla kompilatora TDM-GCC 4.9.2. Dokładna wersja SFML do tego to własnoręcznie skompilowana.
https://www.sfml-dev.org​/download/sfml/2.5.0/
Nie jest tam czasem napisane czerwonym wytłuszczonym drukiem, jakie dokładnie wersje kompilatorów powinieneś mieć, by bezproblemowo używać gotowych buildów..? Twoja wersja kompilatora jest dość stara, nie ma powodu dla którego nie miałbyś zrobić upgrade do TDM-GCC 5.1.0, które jest jedną ze wspieranych wersji.
https://sourceforge.net​/projects/tdm-gcc/files​/TDM-GCC%20Installer​/tdm-gcc-5.1.0-3.exe/download
P-172297
» 2018-09-15 17:57:50
1. msys2 (sfml ma w repozytoriach) https://www.youtube.com/watch?v=OKhVwEpqNp0 IDE nie ma znaczenia ja wyjaśniam na codeblocks (wersja samo ide bez kompilatora)
2. visual studio i nuget
3. doprowadzić do sytuacji aby twój kompilator był w tej samej wersji co użyty do kompilacji biblioteki sfml.  
4 samodzielnie skompilować bibliotekę swoim kompilatorem
P-172325
« 1 »
 Strona 1 z 1