[SFML] Aplikacja testowa nie uruchamia się
Panel użytkownika
Nazwa użytkownika:
Hasło:
Nie masz jeszcze konta?
Zarejestruj się!

[SFML] Aplikacja testowa nie uruchamia się

AutorWiadomość
Temat założony przez niniejszego użytkownika
[SFML] Aplikacja testowa nie uruchamia się
» 2015-12-21 12:08:28
Witam,

od jakiegoś czasu próbuję skonfigurować SFML w Code Blocks 13.12, jednak aplikacja testowa nie chce się uruchomić. Tzn. w momencie, w którym mój Build Target to GUI Application, Code Blocks zawiesza się po naciśnięciu przycisku Build and run. Jeżeli mój Build Target to Console Application, konsola pokazuje się, ale nie pojawia się okno SFML'a. Jeżeli zamknę konsolę, to proces cały czas zostaje aktywny w tle i nie da się go zakończyć.

Moje build options (wszystko pod Debug, Release mam puste):

#defines:
SFML_STATIC

Linker Settings -> Link libararies:
sfml-graphics-d
sfml-window-d
sfml-system-d
sfml-audio-d
sfml-main-d
sfml-network-d

Search directories -> Compiler
Ścieżka do folderu include

Search directories -> Linker
Scieżka do folderu lib

Mój kompiler: GNU GCC Compiler

Moja wersja SFML: SFML 2.3.2 Windows 4.8.1 TDM 32-bit

Mój system: Windows 7


P-142209
» 2015-12-21 12:18:56
W takiej konfiguracji aplikacja nie powinna się nawet skompilować chyba że w kodzie wogóle nie użyłeś SFML.
Tu masz tutka jak poprawnie skonfigurować SFML w C::B http://www.sfml-dev.org​/tutorials/2.3/start-cb.php
P-142210
Temat założony przez niniejszego użytkownika
» 2015-12-22 13:38:27
W końcu, po milionie prób i przeinstalowań C::B, udało mi się uruchomić aplikację testową. Dzięki za pomoc. Zamykam temat.
P-142237
« 1 »
 Strona 1 z 1